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RM Unify Network Agent error: Unable to connect to the remote server. No connection could be made
Published Date : 22 May 2023   Last Updated : 04 Oct 2024   Content Ref: TEC9174635  





Symptoms

User and password synchronisation is not working and the following errors are reported in the RM Unify Network Agent log:

Source: RM Unify Network Agent
Detail: System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 23.102.57.220:443 at System.Net.Sockets.Socket.InternalEndConnect

Source: RM Unify NA ResultsIoader
Detail: System.AggregateException: One or more errors occurred. ---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it <x.x.x.x> at System.Net.Sockets.Socket.InternalEndConnect

You can view these errors from Event Viewer, RM Unify Network Agent log and in the C:\ProgramData\RM\RM Unify Network Agent\Logs\RM.Unify.NetworkAgent.log file.



Cause

This can occur when the Network Agent is configured with incorrect proxy settings. When the Network Agent first runs, it uses the proxy settings of the user signed into the server or, failing that, a user who has previously signed in.



Procedure

  1. Sign into the server as a user.
  2. Confirm that the user can use a browser to access the Internet. If they cannot, configure Internet Options with the correct proxy settings to allow the user Internet access.
  3. Open services.msc
  4. Stop and start the RM Unify Network Agent Service.


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Document Keywords: RM Unify network provisioning, rmuvnp, rmunp, vanilla, non-cc4, cc4,


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