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"UPTERROR. User... Management Information about this User appears to be corrupt" error message in RM Unify Audit log
Published Date : 05 May 2021   Last Updated : 09 Feb 2023   Content Ref: TEC7855411  





Symptoms

You are using RM Unify Network Provisioning on a Community Connect® 4 (CC4) network. An RM Unify user account has been updated, but the update has not been applied to the linked AD account and the RM Unify User Audit log reports an error message as below:

UPTERROR. User: username. Primary TSA '[CC4]' Reported the following issue: 'This User exists in the [AD] and RM UP believes it is managing the User however the User cannot be found in [CC4]. Management Information about this User appears to be corrupt and needs to be corrected.'



Cause

This error can have multiple root causes and is usually associated with inconsistencies in the user's CC4/AD account. The most common is:

The sAMAccountName value of the affected AD account does not match the existing RM Unify username, although the 'User logon name' does. This may happen when the RM Unify or AD account has been updated manually to a name greater than 20 characters. The RM Unify username and the AD 'User logon name' values match the longer name, but Windows has automatically truncated the sAMAccountName value to 20 characters.



Procedure

  1. In the CC4 Management Console, rename the affected user using a new username of less than 20 characters. This will correct the AD account so that the 'User logon name' and sAMAccountName AD attributes match.
    Note: If the rename fails with an error in the CC4 Management Console, run a health check against the user, resolve any issues identified in the health check log and try the rename again.
  2. Open 'Active Directory Users and Computers' and confirm that View, Advanced Features is ticked.
  3. Browse to the affected user account (do not use the Search feature as this hides the Attribute Editor tab needed in step 5 below).
  4. Double-click the user account.
  5. Select the Attribute Editor tab.
  6. Click Filter and select 'Show only writable attributes'.
  7. Select each of the below attributes, click Edit and Clear:
    • rmCom-ImmutableIdentity
    • rmCom-ManagementInformation
    • rmCom-MisId
  8. Click OK and close the windows.
  9. In the RM Unify Management Console, rename the affected user to the new username chosen in step 1 above.
  10. Wait for five to ten minutes and check the RM Unify user audit log for a successful 'Update AD user' change.
  11. Confirm if the user can sign on to the network with their new AD account name and access all the existing user data and resources, including profile, if applicable.


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Document Keywords: mgt console, auditing, user audit, event type, rm unify audit, audit log, rmunp, rmunvp, fail to update, TEC7855411


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