RM Unify - How to move from CSV provisioning to AD Sync provisioning
Published Date : 16 Jan 2019
Last Updated : 04 Oct 2024
Content Ref: TEC6606766
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Summary
Details the checks and steps required before moving from the CSV user provisioning method to AD Sync provisioning.
Symptoms
You have an RM Unify Premium establishment and have previously provisioned your user accounts via upload of a manually created CSV file, or via the 'Create user' option in the Management Console. You now want to install RM Unify AD Sync.
Cause
If you have previously used the RM Unify CSV Extraction Tool (refer to DWN3182515 in the Other Useful Articles section below), your RM Unify CSV accounts will be provisioned using the ObjectGUIDs of your network users. Using this GUID means that the RM Unify datacentre already has that unique ID with which to identify your users, so that when you switch to AD Sync provisioning, the same ObjectGUID is sent to RM Unify and there is a seamless transition for the accounts, from CSV to AD provisioning.
However, if you provisioned your CSV users by manually creating a CSV file without these ObjectGUIDs, there is a risk that the install of AD Sync will duplicate your RM Unify user accounts, as well as any Microsoft® 365™ or Google Workspace accounts that may be linked to them. The resultant clean up of these duplicated accounts can be very complex, time-consuming, and include downtime for your users.
Requirements
To check whether your network accounts' ObjectGUIDs match your already existing RM Unify user accounts, you will need to run a simple PowerShell script on your network. The output of this can be compared with an export of your current RM Unify accounts and if the IDs match for all users then you can proceed with the installation of AD Sync.
Procedure
Log on as administrator to a domain controller on your network.
In the right-hand pane, click the 'Generate a CSV of my existing RM Unify users' option. A file named EstablishmentUsers.csv will be downloaded.
Open the EstablishmentUsers.csv file and note that the PersonID column shows a 32 character GUID.
Where a user's PersonID GUID (RM Unify account) matches their ObjectGUID (network account), then their RM Unify account will seamlessly transition from CSV provisioning to AD Sync provisioning.
Where a user's PersonID GUID (RM Unify account) does not match their ObjectGUID (network account), then additional work will be required. Please log a support call with RM Support for further advice on how to proceed.