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How to prevent auto-linking of RM Unify users to their MIS records with MIS Sync enabled
Published Date : 31 Oct 2016   Last Updated : 23 Jul 2024   Content Ref: TEC5341484  





Symptoms

You have MIS Sync enabled and as a requirement for a third party installed app, such as Show My Homework, need your AD Sync provisioned RM Unify users to have MIS IDs populated. Because you do not wish to have the display names of your staff users changed, which happens automatically when you link the accounts to their MIS records, you decide instead to update the staff accounts' MIS IDs via a CSV upload.

However, you find that when an update to those staff user accounts occurs (for example via an AD Sync resync), the staff users are automatically linked to their MIS records.



Cause

This issue occurs because you have enabled MIS Sync for your site. RM Unify expects to treat any RM Unify account with an MIS ID as a candidate for MIS linking. When an RM Unify account is found with an MIS ID matching that of an MIS record we also have stored, that account will, logically, be automatically matched. This is an expected behaviour.


Procedure

To manually undo the MIS link for your users and prevent MIS auto-linking in future:

  1. Log on to the RM Unify Management Console as an administrator - https://launchpad.rmunify.com/ManagementConsole/LinkUsers.
  2. Navigate to those users* linked to their MIS record.
  3. Click the drop-down menu next to View for each user and select Remove.
  4. At the bottom of the page, click Save.
  5. Navigate to the users (they will most likely be in the 'users with a likely MIS record match' section).
  6. Click the drop-down menu next to Link, match for each user and select 'User not in MIS'.
  7. At the bottom of the page, click Save.

*Users with a green L icon have been linked manually by an admin via the UI. Those without the icon have been auto-linked by RM Unify, as a result of the MIS ID being manually populated in the users' accounts.



Checks

The MIS IDs that have been populated via a CSV upload will remain after this procedure. If an AD Sync resync is performed, the users will not now relink, so long as they remain in the category of 'User not in MIS'.


Other Useful Articles

CSV file format for import and export of users in RM Unify (TEC3274284)
How to edit the display name for Teaching or Non-Teaching Staff accounts in RM Unify (TEC5730647)

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Document Keywords: How to prevent auto-linking of RM Unify users to their MIS records with MIS Sync enabled, automatch, matching, autolink, stop link, TEC5341484


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