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RM Unify AD Sync registration fails with log error "System.ServiceModel.ProtocolException"
Published Date : 15 Jul 2015   Last Updated : 03 Oct 2024   Content Ref: TEC4648870  





Symptoms

When you try to register your establishment by clicking Register in the RM Unify Sync Configuration tool, the following error is displayed:

"Registration failed for xxxxx. Please check the log files for more details", where xxxx is the display name of your RM Unify registration.

On checking the most recent log file in C:\Program Files (x86)\RM\RM Unify AD Sync\LogFiles, you also see the error:

"Configuration Tool",ERROR,"btnRegister_Click","Error testing credentials for Unify Login RM Unify () - System.ApplicationException: Unable to connect to RM Unify for <DfE Code>---> System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html>.



Cause

This issue occurs on servers with a missing or corrupt installation of one or both of the following:

  • Microsoft .NET Framework v3.5 SP1.
  • Microsoft® Visual C++ 2010 Redistributable Package.


Requirements

Both of the above products are prerequisites for RM Unify AD Sync.


Procedure

  1. Install or reinstall the affected prerequisites. If you are unsure on how to do this, please refer to the RM Unify AD Sync Release Note.
  2. Uninstall the current installation of RM Unify AD Sync.
  3. Reinstall RM Unify AD Sync and complete registration.


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