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RM Unify AD Sync service stops immediately after starting
Published Date : 18 Jun 2013   Last Updated : 23 Jul 2024   Content Ref: TEC3348242  





Symptoms

The RM Unify AD Sync service stops immediately after starting.

The system log may report the following error for the service:

"Service cannot be started. System.InvalidOperationException: Unable to generate a temporary class (result=1).
error CS2001: Source file 'C:\WINDOWS\TEMP\filename.cs' could not be found", where C:\WINDOWS\TEMP\filename varies depending on your installation location.



Cause

There are two possible causes of this issue:

  1. If the system log reports the error noted in the Symptoms section above:
    The identitysyncservice user configured to log on as the RM Unify AD Sync service has insufficient permissions to the folder specified e.g C:\Program Files (x86)\RM\RM Unify AD Sync\LogFiles. 
  2. If the system log does not report an error, then it may be that the identitysyncservice user has insufficient permissions to the C:\Program Files (x86)\RM\RM Unify AD Sync folder.


Procedure

If the system log reports the error noted in the Symptoms section
  1. Assign the identitysyncservice user the following permissions on the folder specified in the error message:
    • Read & execute.
    • List folder contents.
    • Read.
  2. Restart the RM Unify AD Sync service.

If the system log does not report an error

Assign Modify permissions on the C:\Program Files(x86)\RM\RM Unify AD Sync Service folder for the identitysyncservice user.



Other Useful Articles

RM Unify AD Sync service intermittently stops (TEC6891805)

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Document Keywords: 3348242, unify, proxy, sync


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