Error "Hmm. Your browser version isn't supported." displayed while using Microsoft Teams via a web browser on a mobile device
Published Date : 15 Oct 2020
Last Updated : 23 Jul 2024
Content Ref: TEC7503673
Operating System
(none)
Part No
(none)
Summary
Explains why you may receive the error message ""Hmm. Your browser version isn't supported." when trying to log on or access Microsoft Teams via a web browser on your mobile device.
Symptoms
You have clicked a Microsoft® Teams URL and see the following error message: "Hmm. Your browser version isn't supported. Quickest solution? Download the mobile app".
Cause
Microsoft Support have advised that this is an expected behaviour and that the Microsoft Teams app must be used on mobile devices.
Possible Issues
If you have an RM Unify federated Microsoft 365 account, you will be presented with the RM Unify logon page when accessing the Teams app. You should enter your Microsoft 365 email address and RM Unify password to log on. Once logged on, you will remain authenticated until your password changes, or your account is unlicensed.
If this article has not helped provide a solution then it is also possible to
log a call...
Document Keywords: teams, ms, authenticate, authenticating, logging on, logging in, logon, login, TEC7503673