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RM Unify AD Sync service intermittently stops
Published Date : 16 Aug 2019   Last Updated : 04 Oct 2024   Content Ref: TEC6891805  





Symptoms

The RM Unify AD Sync service intermittently stops with the following symptoms: 

  • RM Unify AD sync log file contains "System.OutofMemoryException" errors a few minutes before the service stopped
  • The System log contains EventID: 7031 Service Control Manager with the description "The RM Unify AD Sync Service service terminated unexpectedly"
  • The C:\Program Files(x86)\RM\RM Unify AD Sync\RM.Networks.IdentityManagement.sdf file is greater than 10 MB

You can restart the service successfully but it will stop again after a random time period, ranging from a few minutes to a few hours. 

The RM Unify AD Sync log file may contain other 'System.OutofMemoryException' errors that do not correlate to the time the service stopped.



Cause

This can occur when there is a large number of rows in the 'UnifyStatusMessages' table on the local AD Sync database - the RM.Networks.IdentityManagement.sdf file.


Requirements

To resolve this issue, please reinstall RM Unify AD Sync, please see article TEC5015612 in the Other Useful Articles section below.

If you have a multi-site installation of RM Unify AD Sync and will be unable to efficiently re-configure AD filters, please contact RM Cloud Support for further assistance.



Other Useful Articles

How to create a clean RM Unify AD Sync database (TEC5015612)
RM Unify AD Sync service stops immediately after starting (TEC3348242)

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Document Keywords: 6364760, asdsync, rmunify, RM Unify AD Sync service intermittently stops, outofmemory, exception, out of memory, system.outofmemoryexception, database, dbase unify, sdf, shrink, reduce, stopping, adsync, outofmemoryexception, TEC6891805


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