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RM Unify AD Sync registration fails or user changes don't upload with log error "failed to construct connection to Unify server"
Published Date : 17 Apr 2019   Last Updated : 13 Mar 2023   Content Ref: TEC6760913  





Symptoms

You have one of the following symptoms:

  1. Registration fails in the RM Unify AD Sync Config tool with error:
    "Registration failed for <UnifyEstablishment>. Please check the log files for more details", where xxxx is the display name of your RM Unify registration".
  2. AD user and password changes are not uploading to RM Unify.

On checking the most recent log file in C:\Program Files (x86)\RM\RM Unify AD Sync\LogFiles, you also see the error:

"System.ApplicationException: Failed to construct connection to Unify server ---> System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms".



Cause

This issue occurs when the security policy applied to the RM Unify AD Sync server is set to use FIPS compliant algorithms for encryption, hashing and signing. This setting is not compatible with RM Unify AD Sync.

Please consult your network administrator to find out if and how, to disable FIPS on the server. They will also be able to advise if the FIPS settings are delivered from the server's local security policy or via GPO. We have provided instructions below on how to disable it in a server's local security policy.

If FIPS should not be disabled on the server then you may like to consider moving RM Unify AD Sync to a different server. Please refer to TEC5831682 in the Other Useful Articles section below.



Procedure

Disable FIPS from the local security policy
  1. On the RM Unify AD Sync server, log on as the administrator.
  2. Right-click the Windows button and click Run.
  3. Type secpol.msc and click OK.
  4. Under Security Settings, expand Local Policies.
  5. Click Security Options.
  6. From the right-hand window, double-click 'System cryptography: Use FIPS compliant alogrithms for encryption, hashing and signing'.
  7. Click Disabled, Apply.
  8. Click OK and close the Local Security Policy window.
  9. Reboot the server.


Other Useful Articles

How to move RM Unify AD Sync to a new server in the same Active Directory (TEC5831682)

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Document Keywords: ad, sync, ad, config, tool, Failed to construct connection to Unify server, fips, TEC6760913


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