Local AD password changes generate application log error "ReportPasswordChange thread exit code -2146233082"
Published Date : 09 Apr 2019
Last Updated : 03 Oct 2024
Content Ref: TEC6692731
Operating System
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Part No
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Summary
Explains why RM Unify Password Filter is unable to create a .json file and why an error is generated in the application log.
Symptoms
You are using RM Unify AD Sync to provision network accounts and sync password changes to RM Unify. You find that password changes are not being synced to RM Unify and an error, shown below, is logged to the domain controller's (DC) application log:
Other network account changes such as display name are being synced to RM Unify.
Cause
When processing a network account password change, RM Unify AD Sync temporarily creates a .json file in the \\<DCNAME>\RMNetIdentityQueue$ share location on the domain controller. Anti-virus or other protection software such as Sophos, however, may prevent RM Unify AD Sync from processing the password change fully and from creating the temporary .json file. When this happens, an error may be written to the DC's application log.
Procedure
Please consult your anti-virus/protection support provider on how to exclude the 'C:\Program Files\RM\RM Unify Password Filter' folder and sub-folders on each DC. Depending on the software, you may have to complete additional tasks to allow RM Unify Password Filter to function while the protection is on.
Checks
It has been found with Sophos that the exclusions to the 'C:\Program Files\RM\RM Unify Password Filter' folder only take effect on the server when the anti-virus features within the Sophos management console are 'toggled' off and back on.
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