Possible issue when adding next year's student users to RM Unify
Published Date : 07 Jun 2018
Last Updated : 04 Oct 2024
Content Ref: TEC6268715
Operating System
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Part No
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Summary
Describes an issue relating to the year of entry of RM Unify student user accounts that get created in advance of them starting at the school.
Symptoms
You are using RM Unify MIS Sync in Create mode and have students and/or staff at your school who require RM Unify accounts to be created, in advance of those users actually being on roll in your MIS; you wish to pre-provision their accounts (also called pre-admission). For example, it is June/July and, whilst your users are actually off roll, you would like their RM Unify accounts to be created, ready for the start of the new academic year.
However, you find that your pre-provisioned students have a year of entry which corresponds to the current intake year and not the next intake year as one might expect. This affects their year group membership and possibly also their username.
When the student is fully admitted on to the school roll (once they start attending\studying at the school), the student's year of entry attribute will be updated to reflect their actual intake year. However, their username will not be automatically updated to their actual intake year.
Cause
This is expected behaviour in RM Unify.
Accepted student user data is extracted in such a way that it presents the user in the year group they are accepted for, even though technically they are not yet on roll in the school, and probably in reality are in the year below (if, say, moving from primary to secondary).
All the data messages that RM Unify receives from the MIS in your school are populated with the current intake year, as you would expect. Currently, RM Unify is unable to discern if the user data within those data messages relates then, to:
a user entering the school in the current academic year and who will begin studying in that same year, OR
a user being entered into the MIS who actually will start studying in the next academic year.
Where RM Unify usernames are created based on the year of entry, both students would receive accounts with usernames containing the current intake year (2 or 4 digit), e.g. pnelson17@paisleypark.
Procedure
Bulk-renaming of usernames
Log on to the RM Unify Management Console as a super admin and navigate to the Users page.
Using the View filter, select the Role type of the users you wish to rename, e.g Students. Alternatively you could select a specific Year Group.
Use the second drop-down, 'users from', to select MIS as the provisioning source.
Select the Actions drop-down and choose 'Download all users in the group', the file will save to your computer as 'EstablishmentUsers.csv'.
Open the file and delete the users (rows) you do not wish to change.
Make the changes you require to the remaining values in the Username column only and save the file, making sure that it remains saved as the csv file type and not .xls or .xlsx etc.
From the left-hand menu, navigate to Account Settings.
On the Username Formats page, in top-right, select the MIS User Rename button.
Select Browse, select the edited csv file, select Open and then Upload.
Renaming of individual user accounts
Usernames of individual users can be changed via the RM Unify Management Console:
Log on as an RM Unify Super Admin.
From the Management Console, click Users and search for the user.
Click the Actions button and from the drop-down menu, select 'Change username'.
Enter the new username and click Save.
Checks
Please see TEC6902586 in the 'Other Useful Articles' section below for further information about the MIS User Rename functionality.