RM SafetyNet UBF user is prompted for credentials after a network password change
Published Date : 23 Mar 2018
Last Updated : 04 Oct 2024
Content Ref: TEC6169503
Operating System
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Part No
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Summary
Explains why a user may get prompted with an authentication box when browsing the Internet after a network password change.
Symptoms
After a network password change, a user can successfully sign into RM Unify with the new password but gets prompted with an authentication box when trying to browse the Internet. The user needs to enter their old password to get access to the Internet.
This issue may be consistent or intermittent and appear to randomly affect one or more users.
Cause
RM Unify Password Filter on one or more domain controllers is missing a certificate to correctly hash the network password, or has an old version of RM Unify Password Filter installed. If you have multiple domain controllers and only one domain controller is affected, the issue will only appear when the affected domain controller is processing the network password change and hence the appearance of an intermittent or random issue.
Procedure
Check RM Unify Password Filter on every domain controller
On a domain controller, open 'Programs and Features'.
Find RM Unify Password Filter and confirm the installed version is v3.x.x or greater.
If the installed version is v2.x.x or earlier, upgrade to the latest version. For more information, please refer to TEC5797917 in the Other Useful Articles section below.
On the same domain controller, open Windows Explorer and browse to the C:\Program Files\RM\RM Unify Password Filter\RMNetIdentityQueue folder.
Confirm there is an RMUnifyADSyncCert.cer file in the folder.
If the .cer file is missing, browse to the server with RM Unify AD Sync installed and manually copy (not move) the RMUnifyADSyncCert.cer file from the C:\Program Files (x86)\RM\RM Unify AD Sync.