How to delete an AD Sync provisioned RM Unify user that no longer exists in Active Directory
Published Date : 13 Jan 2017
Last Updated : 03 Oct 2024
Content Ref: TEC5477146
Operating System
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Part No
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Summary
Explains how to delete an AD Sync provisioned RM Unify user that no longer exists in Active Directory.
Symptoms
One or more user accounts provisioned from Active Directory (AD) are showing in the RM Unify Management Console even though the user account has been deleted from AD. They may or may not be listed in the RM Unify AD Sync Config Tool and you want to delete the orphaned RM Unify account.
Cause
This issue occurs because, the user accounts provisioned and subsequently deleted from AD may not get deleted from RM Unify in the following circumstances:
RM Unify AD Sync was not running at the time of AD account deletion and was later reinstalled/upgraded.
There was/is a replication issue between domain controllers at the time of deletion.
The AD account did not match an AD filter in the AD Sync Config Tool at the time of deletion.
Requirements
Check if the user is showing in the AD Sync Config Tool
Open the AD Sync Config Tool.
At the bottom left-hand side, click the Users container.
On the right-hand side, from the Filter By drop-down menu, select All Users.
Check if the user is listed. You can sort the column alphabetically by clicking the column heading.
Procedure
The user is not showing in the AD Sync Config Tool
If the user is not showing in the AD Sync Config Tool, follow the instructions in TEC5476566 in the Other Useful Articles section below.
The user is showing in the AD Sync Config Tool
If the user is still showing in the AD Sync Config Tool, then a 'resync with delete' alone is unlikely to delete the orphaned RM Unify account. In this situation, you will want to create a new (clean) AD Sync database first and then run a 'resync with delete'. The procedure will be:
Create a new AD Sync database by following the instructions in TEC5015612 in the Other Useful Articles section below.
Confirm if all the desired RM Unify users are showing under each AD filter in the AD Sync Config Tool.
Run a 'resync with delete' by following the instructions in TEC5476566 in the Other Useful Articles section below.