AD Sync Config tool does not display Year of Entry (YOE) on a CC4 network
Published Date : 24 May 2016
Last Updated : 04 Oct 2024
Content Ref: TEC5175742
Operating System
Community Connect 4
Part No
(none)
Summary
Explains why the AD Sync Config tool does not display Year of Entry (YOE) on a CC4 network.
Symptoms
On a Community Connect® 4 (CC4) network, the RM Unify AD Sync Config tool does not display or upload the Year of Entry (YOE) for some or all users. The AD Sync log file also contains the following error for affected users:
"Failed to get YOE for User <user name>" followed by "System.ArgumentException: An item with the same key has already been added".
Cause
This will occur if the user has been uploaded to RM Unify by an AD attribute value other than their objectGUID. On CC4 sites, if a user has a populated rmCom2000-UsrMgr-UpN attribute value then RM Unify AD Sync will upload the user by that value rather than their objectGUID.
Procedure
As a workaround, MIS Sync for RM Unify can be used to upload and populate YOE for RM Unify users. To find out how to deploy MIS Sync for RM Unify, please ask your RM Unify administrator to: