Error "RM.Networks.IdentityManagement.ConfigTool has stopped working" displayed when you try to save AD filter on RM Unify
Published Date : 29 Oct 2015
Last Updated : 04 Oct 2024
Content Ref: TEC4835089
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Summary
Explains why the error message "RM.Networks.IdentityManagement.ConfigTool has stopped working" is displayed when you try to save AD filter or role mapping on RM Unify.
Symptoms
When you try to save an AD filter or role mapping in the RM Unify AD Sync Configuration tool, the error below is displayed: "RM.Networks.IdentityManagement.ConfigTool has stopped working".
On looking in the Windows® server application log files you may also see the event ID 16397 with the description below: "Windows(R) Lightweight Directory Access Protocol (LDAP) failed a request to connect to Active Directory Domain Services(R) for Windows user <DOMAIN\identitysyncservice>".
Cause
This has been known to occur in the following instances:
the AD security group you are trying to use in the AD filter or role mapping failed to create successfully.
in the AD filter, the distinguished names of the organisational unit and the desired group both contain an OU or CN with name Users.
Procedure
The AD group failed to create successfully
To resolve this issue, follow the steps below:
Using 'Active Directory Users and Computers', view the membership of the security group you have been trying to use in the AD filter or role mapping.
There should be no members but, if there are, make a note of them.
Delete and recreate the security group; you can use the same or a new group name.
Add any members you found in step 2.
Create the AD filter or role mapping using the newly created group.
The distinguished name contains an OU or CN with name Users
To resolve this issue, follow the steps below:
Move the desired group to a new location in AD, where its distinguished name does not contain an OU or CN with name Users. The group name itself can retain the word Users, e.g. RM Unify Users.
Checks
Neither of the solutions work?
If you find neither of the solutions work and your issue is with the creation of an AD filter, try adding the group to the AD filter first before selecting the container for the AD filter.
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