Error "RM Unify AD Sync Setup",ERROR,"FindMostAppropriateDC" displayed during installation of RM Unify AD Sync
Published Date : 25 Mar 2015
Last Updated : 04 Oct 2024
Content Ref: TEC4458850
Operating System
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Summary
Explains why an error message "RM Unify AD Sync Setup",ERROR,"FindMostAppropriateDC" is displayed during the installation of RM Unify AD Sync and how to resolve it.
Symptoms
Installation of RM Unify AD Sync has paused at the RM Unify AD Sync Service Configuration Editor dialog box. The AD domain controller server box is blank and you cannot manually populate it. If you try to progress you are presented with a "Please specify a domain controller" message. When you look in the RM Unify AD Sync log, you see the following error:
"RM Unify AD Sync Setup",ERROR,"FindMostAppropriateDC","Cannot resolve the most appropriate DC. <DCName> - System.DirectoryServices.ActiveDirectory.ActiveDirectoryOperationException: Property "dNSHostName" not found, where <DCName> is the fully qualified domain name (FQDN) of the server you are installing RM Unify AD Sync on.
Cause
This error occurs if any domain controller (DC) on the network is missing a value in the dNSHostName attribute. This attribute should be populated for all DCs by default.
Procedure
Check the dNSHostName attribute in the 'Default naming context'
Log on to the server as an administrator user.
Click Start, Run, type adsiedit.msc and press Enter.
Right-click ADSI Edit and select 'Connect to'.
Under Connection Point, from the 'Select a well known Naming Context' drop-down menu, select 'Default naming context'.
Click OK.
Expand the Default naming context on the left-hand side to find and click the container OU=Domain Controllers.
For each DC listed, right-click and select Properties.
Find dNSHostName attribute.
Check it contains the fully qualified domain name of the DC.
If it does not, select the dNSHostName attribute and click Edit.
Enter the FQDN of the server.
Click OK and OK again.
Check the dNSHostName attribute in the 'Configuration context'
Log on to the server as an administrator user.
Click Start, Run, type adsiedit.msc and press Enter.
Right-click ADSI Edit and select 'Connect to'.
Under Connection Point, from the 'Select a well known Naming Context' drop-down menu, select Configuration.
Click OK.
Expand the Configuration context on the left-hand side to find and click the container CN=Sites.
Expand each site listed. By default, there is one called CN=Default-First-Site-Name but on your network this may have been renamed or you may have additional sites configured.
Expand the container CN=Servers.
For each DC listed, right-click and select Properties.
Find dNSHostName attribute.
Check it contains the fully qualified domain name of the DC.
If it does not, select the dNSHostName attribute and click Edit.
Enter the FQDN of the server.
Click OK and OK again.
Once you have checked and corrected the dNSHostName attribute of all DCs, rerun the RM Unify AD Sync installation.
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