RM Logo
Technical Rating: 
Support Home PageSupport
Print This PagePrint This Page
Add to 'My Library' Add to 'My Library'

RM Unify Password Filter or AD Sync fail to install
Published Date : 16 Mar 2015   Last Updated : 14 Feb 2023   Content Ref: TEC4457959  





Symptoms

You run the RM Unify Password Filter.msi or RM Unify AD Sync.msi file but it fails to complete the installation successfully. You may see one or both of the following errors:

  • MSI Error 1722: There is a problem with this Windows Installer package.
  • In event viewer application log, EventID: 11722
    Product: RM Unify <product name> -- Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action ShareFolder, location: C:\Program Files\RM\RM Unify Password Filter\RM.Networks.IdentityManagement.SetupShare.exe.


Cause

Installation has been known to fail due to the following issues:

  • One or more User Access Control (UAC) settings are preventing the installation from completing.
  • The .msi file has been blocked due to Windows® security.
  • Windows has detected errors in the .msi file.
  • The logged on user has insufficient permissions.


Procedure

Temporarily disable UAC
  1. Click Start, Control Panel, User Accounts.
  2. Click 'Change User Account Control settings'.
  3. Move the slider to 'Never notify'.
  4. Click OK.
  5. Rerun the .msi file to complete the installation.
  6. On successful installation, follow steps 1-4 to change the UAC settings to its previous value.

Unblock the .msi
  1. Right-click the .msi and select Properties.
  2. Click the General tab, Security.
  3. Click Unblock.
  4. Click the .msi and complete the installation.

Run the program compatibility troubleshooter
  1. Right-click the .msi file and select Troubleshoot Compatibility.
  2. Allow the troubleshooter to detect and resolve any issues found.
  3. Click 'Test the Program' to relaunch the .msi file and complete the installation.

Logged on user has insufficient permissions
Even if you are logged on as a user with administrative privileges or as a member of an admin group, this user may still have insufficient permissions to allow the installation to complete. Please log on using the domain administrator account for your network and run the installation again.


FEEDBACK
Did the information in this article help answer your question?
 Yes
 No
Please add any comments about this article in the box below. If you answered No then it is important you tell us why so that we can change the article if required. We can only respond if you log in to the RM Support website or provide your contact details. Note: If you need help with a technical query, please log a call online or telephone our support team.
Thank you for your feedback, which is sent directly to the RM Knowledge team. We address every message received with the intention of improving our Knowledge Library articles. If you have an unresolved technical issue, please contact RM Support.


If this article has not helped provide a solution then it is also possible to log a call...



Document Keywords: ad, sync, ad, rmpassword, unify, TEC4457959


Please read - important disclaimer information.
http://www.rm.com/_RMVirtual/Includes/csredirect.asp?cref=&title=Standard Content Disclaimer


Top Of PageTop of page